In order to work on the training exercises you will need a training slot on the virtual server we provide in the Azure cloud. However, please note that - even though migFx can run on a cloud-based virtual machine - it is not a cloud based solution. The training slot setup is simply a way to provide you an updated and efficient training environment to learn about migFx. 


To get a training slot you must first contact us on support@hopp.tech. We will then provide you with the necessary credentials (username and password) for you to connect to your training slot via remote desktop.


Once connected, you have the entire migFx at your disposal in an your own, isolated sandbox. migFx comes with a default setup, but you must do some customization before starting the exercises.


Connect to your slot on the server

On your own Windows machine, you can start the Remote Desktop Client by searching for Remote Desktop Connection in the Windows Start menu. Use the IP address, username and password provided by hopp to connect to remote server.


For the rest of this section, and indeed for the entire remaining exercises, we assume that you are connected to your slot on our server.


From time to time, we at hopp will need to update migFx in the training environment. It is a great help to us if you sign off your Remote Desktop session, when you are not working on the exercises (as opposed to just disconnecting the session by closing the Remote Desktop window on your computer). You sign off from the Windows Start Menu as shown below:


Prepare Studio workshop projects

  • Find and open the Studio application

 

  • Setup general Studio options:
    • Go to Tools > Options
    • Click on View > General
      • For the Project folder, click the browse button ('...') to select your Mapping folder:
        Note that the selected folder will appear as D:\MigFx\Workshop\Training\Trainees\TraineeXX\MigFx\Mapping, where XX is your trainee number
    • Click on Repository > General
      • Select the Server radio button and specify Server as (localdb)\mssqllocaldb and database as migFx_Repository
      • Click test, to verify the connection between Studio and the Repository
    • Click Ok


When you are working in Studio, you are in fact modifying files that reside locally in the folder you have just specified above. In order to collaborate with other members in your team, the Studio allows you to check these files in and out of a central repository. Above you have just specified and tested the connection to this repository. 


Setup workshop Source map

When working in Studio on the Source and Target maps, you will be specifying manual rules. These rules must of course me implemented afterwards - using Microsoft Visual Studio. In this section you will setup a link between the migFx Studio and Microsoft Visual Studio to facilitate easy import of rule implementations into migFx Studio from Visual Studio (for documentation and cross-referencing purposes).


In the initial state of your training slot, the Workshop Source- and Target maps only exist in your local folder. In this step you will also be adding the projects to the repository, making them available for collaboration with your team.


  • Open the Workshop Source map from local folder
    • Click the Open Project buttonin the Toolbar
    • Navigate to folder Documents > MigFx > Mapping > Workshop > Source (full path: D:\MigFx\Workshop\Training\Trainees\TraineeXX\MigFx\Mapping\Workshop\Source, where XX is the trainee number)
    • Locate and select the fileand click the Open button to open the project
  • Setup project options
    • Go to Tools > Options
    • Click on Manual method implementation > General
    • Check Enable import of manual method implementation
    • For Project folder, navigate to and select: Documents\MigFx\VisualStudio\Workshop\Projects\Workshop\Workshop.SourceEngineCustom (full path: D:\MigFx\Workshop\Training\Trainees\TraineeXX\MigFx\VisualStudio\Workshop\Projects\Workshop\Workshop.SourceEngineCustom, where XX is the trainee number)
    • Click Ok to close the Options dialog
  • Add project to repository control
    • Click the Add project to repositorybutton in the Toolbar and click the Ok button to add all your local files to the repository

Setup Workshop Target map

  • Load Workshop Target map from local folder
    • Click the Open Project buttonin the Toolbar:
    • Navigate  to folder Documents > MigFx > Mapping > Workshop > Target (full path:  D:\MigFx\Workshop\Training\Trainees\TraineeXX\MigFx\Mapping\Workshop\Target, where XX is the Trainee number)
    • Locate and select the fileand click Open to open the project
  • Setup project options
    • Go to Tools > Options
    • Click on Manual method implementation > General
    • Check Enable import of manual method implementation
    • For Project folder, navigate to and select: Documents\MigFx\VisualStudio\Workshop\Projects\Workshop\Workshop.TargetEngine (full path: D:\MigFx\Workshop\Training\Trainees\TraineeXX\MigFx\VisualStudio\Workshop\Projects\Workshop\Workshop.TargetEngine, where XX is the trainee number)

      • Click Ok to close the Options dialog

    • Add project to repository control
      • Click the Add project to repository buttonin the Toolbar and click the Ok button to add all your local files to the repository


There are 2 more sets (Source + Target map) of projects you might want to setup but this is not really required to complete the training exercises: WorkshopDemo source and target, and Sandbox source and target.

  • WorkshopDemo is a suggested solution to the training exercises
  • Sandbox is 'empty', setup for you to use if you want to try things out on a project of your own
  • To setup these, repeat the above sections replacing Workshop with WorkshopDemo and Sandbox as needed

Check Visual Studio

Visual Studio should already be properly setup and ready. This is just a check that this is the case. 


In our training setup, Visual Studio should remain signed in to our MigFx Trainee account. We aim to refresh these credentials regularly, but Visual Studio may prompt you to reenter the credentials with a yellow warning triangle, like so:


Please refrain from doing so. If you find the yellow triangle annoying, you are welcome to contact us and we will refresh the credentials for you. Though you don't have to, the Visual Studio will work just fine anyway.


  • Find and open Visual Studio 2017 (please ensure that you are in fact starting Visual Studio 2017 (and not other versions of Visual Studio that may also be installed on the server))
  • Open Workshop solution
    • Click File > Open > Project/Solution
    • Go to folder Documents > MigFx > VisualStudio > Workshop (fFull path: D:\MigFx\Workshop\Training\Trainees\TraineeXX\MigFx\VisualStudio\Workshop, where XX is the trainee number)
    • Locate an select Workshop.sln and click Open
    • Solution Explorer should contain these 10 projects:


If you check Help/About, you will notice you are using Visual Studio Community Edition. This is the free version of Visual Studio and it is perfectly sufficient for the needs of migFx. 



Check that Director is available and the Service is running

The Director is available in the Windows notification area in the right-hand lower corner of your screen.

  • Click on the Director iconto open the Director context menu
  • Open Workshop -> Training (HOPP01 – Track 1)
  • You will get to the Director in later exercise. For now just verify that the Service is running (green dot vs red dot)


  • The Service is started for you when you sign on to the server. If the Service is not running, try to sign off and on again. If it is still not running, please contact Support
  • The Track is most probably not running. Don't worry either way - that's something for later exercises

Verify that Tracker is available

  • Locate and open Internet Explorer
  • This page (or the following) should be visible:
  • Click on Workshop – System test in Track drop down at the upper right corner. This page should be appear (it may already appear on opening Internet Explorer):
  • If Tracker is not available, please contact Support

Congratulations! Now you have completed the initial setup of your migFx training slot


  • You have set the default location for Studio to look for mapping projects on your local disk
  • You have connected to the repository common for your team to start collaborating
  • Your have told Studio from where to import rule implementations from the Workshop Source- and Target maps
  • You have verified your Visual Studio installation and located the Workshop Engine solution
  • You have verified that you have access to the Director and the Workshop track and that the Director Service is up and running
  • Finally you have verified that you have access to the Tracker application and can see the results of the latest migration run